« Ubuntu(Linux)でExif情報(撮影日時)を書き換える | トップページ | [QGIS1.9]AddAttributeが使えない »

2013年7月 7日 (日)

[QGIS1.9(QGIS2.0?)]QGIS1.8のプラグインが使えない・・・

日本語環境がよくなることを期待してQGIS1.8からQGIS1.9(nightly)へバージョンアップしたら、今まで作っていたプラグインが使えなくなっている・・・

他の公開されているプラグインをみると metadata.txt というファイルが増えている・・・。

中身を見ると今まで __ini__.py ファイルに記述していた内容+αだったので他のプラグインを参考にして記載すると動作した。

ただ、今まで古いバージョンのAPIを知らずに使っていたようで、使えなくなっているAPIがある。

プラグインマネージャーには表示できるようになったが、まだ、動いていない箇所があり、解決策を探すのが一苦労・・・。

でも、日本語のシェープファイルは、正しくレイヤープロパティを設定すると表示できるので今まで問題だった箇所が解決した。

|

« Ubuntu(Linux)でExif情報(撮影日時)を書き換える | トップページ | [QGIS1.9]AddAttributeが使えない »

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/188083/57740001

この記事へのトラックバック一覧です: [QGIS1.9(QGIS2.0?)]QGIS1.8のプラグインが使えない・・・:

« Ubuntu(Linux)でExif情報(撮影日時)を書き換える | トップページ | [QGIS1.9]AddAttributeが使えない »